[xsde-users] using xsd/e on macOS 10.15

Boris Kolpackov boris at codesynthesis.com
Tue Feb 25 09:09:03 EST 2020

Hi James,

James Sutton <jsutton at dolphin-com.co.uk> writes:

> bash-3.2$ make \
> >  CXX="clang++ -std=c++03" \
> >  CPPFLAGS=-I../xerces-c-3.2.2/src \
> >  LDFLAGS=-L../xerces-c-3.2.2/src/.libs \
> >  -j 8
> make: *** No rule to make target `/Users/james/Downloads/xsde-3.3.0.a11+dep/xsde/xsde', needed by `/Users/james/Downloads/xsde-3.3.0.a11+dep/'.  Stop.

Hm, this is strange.

I got hold of a Mac OS machine (with just Command Line Tools installed)
and tried it myself. I didn't get your error but had to fix a compile
error and tweak the command line a bit.

So using xsde-3.3.0.a12+dep[1] with the following command line I got
a working XSD/e compiler executable:

$ make \
  CXX="clang++ -std=c++03" \
  CPPFLAGS=-I../xerces-c-3.2.2/src \
  LDFLAGS=-L../xerces-c-3.2.2/src/.libs \
  LIBS="-framework CoreServices" \
  -j 8

If you want to get to the bottom of this, it must be something about
your setup, most likely make version. Here are the versions of the
relevant programs on my machine:

$ which make
$ make --version
GNU Make 3.81

$ which bash
$ bash --version
GNU bash, version 3.2.57(1)-release

I am also using stock BSD sed:

$ which sed

$ clang++ --version
Apple clang version 11.0.0 (clang-1100.0.33.12)

I've tried to build from both the default shell and bash and both
worked fine.

[1] https://codesynthesis.com/~boris/tmp/xsde/xsde-3.3.0.a12+dep.tar.bz2

More information about the xsde-users mailing list